Back to overview
Testnet Block Explorer is unavailable
Oct 16 at 02:12pm UTC
Affected services
Block Explorer
Block Explorer API
Resolved
Jan 28 at 01:10am UTC
Testnet Block Explorer is unavailable. Working on fixing the issue
Affected services
Block Explorer
Block Explorer API
Updated
Oct 16 at 02:31pm UTC
We’re back! The Hemi Sepolia Block Explorer should be up and running. Thanks for your patience.
Affected services
Block Explorer
Block Explorer API
Created
Oct 16 at 02:12pm UTC
We're investigating an issue with the Testnet Block Explorer which is impacting some users. We're working to fix the problem as quickly as we can. We'll share another update shortly.
Affected services
Block Explorer
Block Explorer API