Back to overview
Degraded

Hemi Sepolia RPC is unavailable

Nov 22 at 03:37pm UTC
Affected services
Public RPC

Resolved
Nov 22 at 05:31pm UTC

Hemi Sepolia RPC is now available

Created
Nov 22 at 03:37pm UTC

We are working on fixing the issue