Back to overview
Degraded

Hemi Sepolia is unavailable

Dec 20 at 05:58am UTC
Affected services
Hemi Portal
Public RPC
Block Explorer
Block Explorer API
Partner RPCs
Hemi Hatchlings
Safe{Wallet}
Swap

Resolved
Dec 30 at 05:14pm UTC

We have resolved this issue, and Hemi Sepolia RPC should now be working correctly for all users. We will continue monitoring for any future issues.

Updated
Dec 20 at 01:14pm UTC

We are aware of another issue affecting Hemi Sepolia and are working on a fix. Sorry for the inconvenience.

Updated
Dec 20 at 09:11am UTC

We have identified the cause of the issue and have made changes to bring the sequencer nodes back online. Sorry for the inconvenience.

Created
Dec 20 at 05:58am UTC

We are currently experiencing an issue with the sequencer nodes on Hemi Sepolia. We are working to fix the problem and restore the network.

Sorry for the inconvenience.