Back to overview
Degraded

Issues affecting Hemi Sepolia RPC

Jan 24 at 03:22pm UTC
Affected services
Hemi Portal
Hemi Sepolia RPC
Block Explorer
Block Explorer API
Safe{Wallet}
Pure Finance
Swap

Resolved
Feb 03 at 04:47pm UTC

This issue has been resolved, and the Hemi Sepolia RPC and Bitcoin Finality Governor should now be accessible.

Created
Jan 24 at 03:22pm UTC

We’re investigating an issue with the Hemi Sepolia RPC that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.