Back to overview
Downtime
Issue affecting hemi.xyz
Sep 24 at 11:33am UTC
Affected services
Website
Hemi Portal
Block Explorer
Block Explorer
Bitcoin Kit Demo
Pure Finance
Swap
Resolved
Sep 24 at 12:13pm UTC
This issue has been resolved. We are continuing to investigate the root cause of this outage. Sorry for the inconvenience.
Affected services
Created
Sep 24 at 11:33am UTC
We are currently investigating an issue affecting DNS queries for hemi.xyz
We will update this post as soon as we have more information. Sorry for the inconvenience.
Affected services