Back to overview
Degraded

Cloudflare service issue

Dec 05 at 09:14am UTC
Affected services
Website
Hemi Portal
Hemi Mainnet Public RPC
Block Explorer
Bitcoin Finality Governor RPC
Partner RPCs
Hemi Sepolia RPC
Block Explorer
Block Explorer API
Bitcoin Finality Governor RPC
Partner RPCs
Bitcoin Kit Demo
Pure Finance
Swap

Resolved
Dec 05 at 09:22am UTC

Cloudflare has marked their incident as resolved. We are continuing to monitor our services closely.

Updated
Dec 05 at 09:18am UTC

We are seeing recovery across our services, and Cloudflare appears to have deployed a fix. We are continuing to monitor the situation.

Created
Dec 05 at 09:14am UTC

We are aware of an upstream service issue affecting Cloudflare which is causing some of our infrastructure to be unreachable. We are monitoring the situation closely.