Issue affecting Hemi Mainnet
Resolved
Jun 25, 2026 at 8:30am UTC
Mainnet is now reliably producing blocks and proposer and batcher are working as expected as of 08:08 UTC. This incident is now resolved, and we are continuing to monitor closely.
Thanks for your patience.
Affected services
Updated
Jun 25, 2026 at 8:20am UTC
We have identified the root cause of this issue being caused by an upstream issue with Ethereum RPC provided by Quicknode: https://status.quicknode.com/incidents/b34nptcs7xl7
We have switched RPC nodes and are currently monitoring recovery.
Affected services
Updated
Jun 25, 2026 at 8:08am UTC
We have identified the cause of the issue and have applied a fix, we are currently monitoring the result. Thanks for your patience!
Affected services
Created
Jun 25, 2026 at 7:47am UTC
We are aware of an issue preventing block production on Hemi Mainnet, and we are currently investigating the cause.
Sorry for the inconvenience.
Affected services